Acceder al contenido principal

La alpha de Composer 2 ya está disponible

Volver a Blog

La alpha de Composer 2 ya está disponible

03 Ago 020
Composer
Ramiro J. Galayo

Composer

Aunque la versión estable tardará en llegar, las primeras alphas de Composer 2 pueden descargarse desde hace unas semanas, y el rendimiento mejora dramáticamente en prácticamente cualquier escenario. 

Los usuarios del CLI deben tener en cuenta estos cambios:

  • La nueva función de comprobación de plataforma (platform-check) significa que Composer comprueba la versión de PHP en tiempo de ejecución y las extensiones disponibles, para asegurar que se corresponden con las dependencias del proyecto. Si se encuentra una discordancia, sale mostrando detalles del error para asegurar que los problemas no se pasan por alto. Para evitar errores al desplegar en producción se recomienda lanzar composer check-platform-reqs con el proceso PHP de producción como parte del proceso de building o de despliegue.
  • Si un paquete existe en un repositorio de mayor prioridad, ahora será ignorado en su totalidad en los repositorios de menor prioridad. 
  • Las configuraciones inválidas de clase PSR-0 / PSR-4 ya no serán cargadas automáticamente en el modo optimized-autoloader, así como las advertencias introducidas en la versión 1.10.
  • En los sistemas Linux que soportan la XDG Base Directory Specification, Composer preferirá utilizar XDG_CONFIG_DIR/composer sobre ~/.composer si ambos están disponibles (la 1.x utiliza ~/.composer first).
  • Los nombres de paquete ahora deben cumplir con las guías de nomenclatura o Composer abortará el proceso, así como los warnings introducidos en la versión 1.8.1.
  • Se ha deprecado la bandera --no-suggest, ya que ya no se necesita.
  • Se ha eliminado el soporte de PEAR (repositorio, gestor de descarga, etc.).
  • El comando update ahora lista primero los cambios al archivo lock (update step), y después los cambios aplicados al instalar el archivo lock al directorio vendor (install step).
  • Si no se especifica el HTTPS_PROXY_REQUEST_FULLURI ahora estará configurado por defecto a false, puesto que parece funcionar mejor así en la mayoría de entornos.

Podéis ver la guía completa de actualización a Composer 2 en su repositorio git.

También podéis probar Composer 2 desde vuestra instalación actual activándolo con el comando:

composer self-update --preview

Y podéis volver a vuestra versión base de Composer 1 con el comando:

composer self-update --rollback

Comentarios

Añadir nuevo comentario